Beacon has been working correctly since we started monitoring.
We are resolving this incident and will be working internally to ensure this problem can't occur again.
Posted Jun 02, 2026 - 16:10 BST
Monitoring
We are now back to normal, but we are monitoring the situation.
Areas that previously were slow/would error, but should now be working as expected are: - Exporting - Suggested Duplicates - Counts and List Views with a large number of records - Dashboard Cards - Developer API - GiftAid
Posted Jun 02, 2026 - 10:36 BST
Identified
Updating components to reflect the outage.
We currently believe this is caused by limits on our BigQuery database system, and are looking into solutions.
Posted Jun 02, 2026 - 10:04 BST
Investigating
We are currently investigating that Beacon is being slower than usual in multiple places for many accounts. This appears to be impacting: - Exporting - Suggested Duplicates - Counts and List Views with large number of records - Dashboard Cards - Developer API
This can result in errors appearing inside of Beacon because actions did not complete in time.
We will update here as we investigate this issue.
Posted Jun 02, 2026 - 09:57 BST
This incident affected: Beacon web application and Developer API.