Intermittent problems with Beacon caused by Pusher
Incident Report for Beacon
Resolved
All systems are operating normally. Sorry for the disruption today.
Posted Nov 14, 2023 - 17:57 GMT
Update
An update from Pusher on the ongoing issue they are experiencing:

Update - We are continuing our investigation into the ongoing issue affecting EU cluster. Our team is actively working to mitigate the problem. While the cluster is slowly recovering, it has not yet reached a stable state.
Nov 14, 2023 - 16:16 UTC
Posted Nov 14, 2023 - 16:17 GMT
Update
We have deployed a fix that will ensure that records can be updated from the Beacon app and the API

Bulk actions, imports, and exports are all still affected.

Workarounds:

- You can run bulk actions, but you won't get a working progress bar. The bulk action itself will continue in the background.
- You will be able to run exports by setting them off and then checking their progress on the export log page.
- Imports will not validate, so importing to Beacon is currently unavailable
Posted Nov 14, 2023 - 16:15 GMT
Identified
We're working on an update that will allow us to bypass the errors being caused by Pusher. We're expecting to deploy a fix within the next hour. Pusher are still investigating the issue on their end: https://status.pusher.com/
Posted Nov 14, 2023 - 15:49 GMT
Investigating
One of our dependencies, Pusher, is experiencing a major outage which is intermittently affecting all Beacon systems. Pusher's status page can be found here: https://status.pusher.com/

Many changes to Beacon are not saving correctly, and the behaviour of all Beacon systems will be unpredictable.

We are actively working on this issue, and intend to immediately remove Pusher as a point of failure.
Posted Nov 14, 2023 - 15:36 GMT
This incident affected: Beacon web application, Developer API, Embedded forms, Forms, and Payments.