Beacon live chat is currently unavailable due to technical issues with Intercom.
Incident Report for Beacon
Resolved
This incident should be resolved. Thanks for your patience while we work through our support backlog.
Posted Feb 22, 2024 - 11:05 GMT
Update
Intercom have published this update:

"We are continuing to work this problem, and do not currently have an ETA for restoration of all functionality."
Posted Feb 22, 2024 - 10:35 GMT
Investigating
We are currently unable to speak with you over live chat. We are waiting for Intercom to resolve the problem. More information from Intercom is available here: https://www.intercomstatus.com/

If you need immediate help you can email us at support@beaconcrm.org
Posted Feb 22, 2024 - 10:13 GMT
This incident affected: Live support chat.