Live chat support disruption
Incident Report for Beacon
Resolved
Support chat systems are functioning normally.
Posted Mar 22, 2023 - 16:42 GMT
Update
Intercom (our live chat provider) have acknowledged the problem and are investigating.
Posted Mar 22, 2023 - 16:20 GMT
Investigating
We're seeing some disruption to our live chat system. Expect a longer than average response time. You can email support@beaconcrm.org in an emergency.
Posted Mar 22, 2023 - 16:13 GMT
This incident affected: Live support chat.