Problems modifying Beacon databases

Incident Report for Beacon

Resolved

All systems are operating normally.
Posted Jul 28, 2026 - 10:13 BST

Monitoring

We're seeing systems returning to normal.
Posted Jul 28, 2026 - 10:10 BST

Update

All users are affected and our engineering team is able to reproduce the problem. We're actively investigating and we'll have a fix as soon as possible. Sit tight.
Posted Jul 28, 2026 - 09:53 BST

Investigating

We're currently investigating reports that some users are unable to create new Record Types.
Posted Jul 28, 2026 - 09:40 BST
This incident affected: Beacon web application.