This incident has been resolved. We're continuing to investigate the causes of system instability over the past few days.
Posted Jun 11, 2026 - 11:05 BST
Investigating
We are urgently investigating reports of list pages and record pages failing to load across multiple Beacon customers. This will also affect the Beacon API and can cause errors on form submissions.
Posted Jun 11, 2026 - 10:32 BST
This incident affected: Beacon web application, Developer API, Embedded forms, Forms, and Payments.