Degraded performance across Beacon systems

Incident Report for Beacon

Resolved

This incident has been resolved.

We are working on an update to mitigate the risk of this issue happening again.
Posted Jun 10, 2026 - 15:43 BST

Investigating

We are investigating reports of Beacon systems running slowly and some pages failing to load.
Posted Jun 10, 2026 - 15:25 BST
This incident affected: Beacon web application, Developer API, Embedded forms, Forms, Payments, and Emails.