Everything seems to be coming back online. We'll continue to monitor for any further disruption.
Posted Jan 27, 2026 - 11:55 GMT
Update
We're starting to see JustGiving come back online for some accounts. We'll continue to monitor the situation.
Posted Jan 27, 2026 - 11:44 GMT
Monitoring
We've confirmed that the problem is on JustGiving's side. We're going to sit tight and wait for them to resolve the issue with their systems.
Posted Jan 27, 2026 - 11:21 GMT
Investigating
We're currently investigating an issue with JustGiving which is preventing our integration from receiving data. You will currently not be able to use the JustGiving integration and it is likely that you will see a warning when you log in to Beacon.
Posted Jan 27, 2026 - 11:03 GMT
This incident affected: Integrations (JustGiving).