Beacon is slow to load
Incident Report for Beacon
Resolved
Things are now back to normal. Thanks for your patience, folks!
Posted Jun 10, 2024 - 17:45 BST
Update
Beacon has now mostly recovered. Form submissions, payment notifications are now fully running and up to date.

Workflow triggers are still delayed.
Posted Jun 10, 2024 - 15:46 BST
Monitoring
We have identified the issue and are starting to see things recovering. Once resolved, we'll restart the areas mentioned.
Posted Jun 10, 2024 - 15:21 BST
Investigating
We are currently investigating an issue where Beacon is slow to load.

As a precaution, we've temporarily paused the processing of Beacon form submissions, payment notifications, and workflow triggers.

Any Beacon forms you're using will still function as normal.
Posted Jun 10, 2024 - 15:02 BST