Rollup field recalculations are significantly delayed
Incident Report for Beacon
Resolved
Rollup field recalculations have now completed. Everything should be fully up-to-date now.
Posted Dec 13, 2023 - 07:37 GMT
Update
The full recalculation of rollup fields across all Beacon accounts is going well. We expect everything to be finished in ~6 hours, by around midnight UK time.

We'll update this status page tomorrow morning to confirm everything is fully resolved.
Posted Dec 12, 2023 - 18:31 GMT
Monitoring
Rollup field values are now recalculating in real-time again. For "batch jobs" (e.g. bulk update, import) there will be a short delay of ~30 -60 seconds after the job finishes before rollup field values are updated.

To ensure nothing gets missed, we're doing a full recalculation of rollup fields across all Beacon accounts, which we expect to take the rest of today. While this recalculation is going on, there will also be a delay in the rollup field values for any new fields you create.

If any values haven't been updated by tomorrow morning, please reach out on support@beaconcrm.org to let us know.
Posted Dec 12, 2023 - 12:37 GMT
Identified
We've identified an issue with some new infrastructure for processing rollup fields which means that there is a delay in updates being processed. We're working on a fix right now.

Currently, rollup fields will take a considerable amount of time to update, you should not rely on the current data in rollup fields until the issue is resolved.
Posted Dec 12, 2023 - 11:36 GMT
This incident affected: Beacon web application.