JustGiving integration is down

Incident Report for Beacon

Resolved

The incident has been resolved on JustGiving's side.

You should start to see your JustGiving records appearing again in Beacon.

If you are still running into issues please reach out to either Blackbaud or Beacon Chat.
Posted Jan 23, 2025 - 16:09 GMT

Identified

JustGiving has confirmed with us the issue is on their side and they are currently working on a fix.

We will update when we know more and will continue to disable the integration on our side while this is happening to reduce disruptions to admins.
Posted Jan 23, 2025 - 13:34 GMT

Investigating

We are currently investigating the issue, but it appears to be a problem on JustGiving's side.

We are looking to disable our API Popup checks while their outage is in place.

There is no update on their side yet, please reach out to them or check out their status page here:
https://status.blackbaud.com/

(No updates there yet).
Posted Jan 23, 2025 - 13:24 GMT
This incident affected: Integrations (JustGiving).